안녕하세요 cocoapods 라이브러리를 만드는데 질문이 있습니다…

태그: 

1 답변 글타래를 보이고 있습니다
  • 글쓴이
    • 3aa0a
      참가자
      • 글작성 : 3
      • 답글작성 : 1
      1,290 포인트

      안녕하세요

      코코아팟 라이브러리를 만들고 있습니다.

      제 Swift 라이브러리에 다른 코코아팟 라이브러리를 포함해서  만드려면 어떻게 해야하나요…

      제 라이브러리 안에 TensorFlowLiteSwift 라는 다른 코코아팟 라이브러리를 넣어야 하는데

      spec dependency 에 추가해서 사용해야하는 건지

      아니면 TensorFlowLiteSwift 파일들을 직접 라이브러리 코드들이랑 위치시켜야하는 지 감이 안잡힙니다.

      spec dependency에 추가하면 그냥 import가 안되고

      코드들을 직접 집어넣으면 TensorFlowLiteSwift 코드들 안에 import TensorFlowLiteC라는 objective C 프레임 워크인지 이친구가 안불러와 집니다… TensorFlowLiteC 프레임워크 파일도 한꺼번에 집어넣은 상태입니다.

       

      어떻게든 TensorFlowSwift를 넣어서 import 하게만 만들 수만 있으면 되는데 iOS 개발 고수님들 도와주세요…

      • 이 게시글은 3aa0a에 의해 1 week, 4 days 전에 수정됐습니다.
    • 야곰
      키 마스터
      • 글작성 : 37
      • 답글작성 : 544
      19,150 포인트

      라이브러리를 직접 가져오는 것은 아니고 의존관계를 만들어주어야겠죠.
      만약 안불러와지면 빌드 한 번 하거나 pod install 다시 해보셨나요? master repo 다시 받아와봐야 할수도 있고요.

      avataravatar
      • 3aa0a
        참가자
        • 글작성 : 3
        • 답글작성 : 1
        1,290 포인트

        podspec만 수정해놓고 pod install을 다시 안하고 있었네요…

        또 s.static_framework = true 이 코드도 빠졌었습니다.

        덕분에 해결됐습니다. 감사합니다!!

        avatar
1 답변 글타래를 보이고 있습니다
  • 답변은 로그인 후 가능합니다.

logo landscape small

사업자번호 : 260-27-00477
통신판매업 신고번호 : 제 2020-충북청주-0663 호
고객센터 : 카카오톡채널 @yagom